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Step-by-Step Guide to OpenSim Exercises and Team Project 

To present some of the tools and capabilities of OpenSim, we will use a simplified model 
(leg6dof9muscles.osim) throughout this workshop. The model consists of the pelvis, thigh, shank, 
and foot segments along with the psoas major, gluteus maximus, rectus femoris, vastus intermedius, 
biceps femoris long head, biceps femoris short head, tibialis anterior, medial gastrocnemius, and 
soleus muscles. This simple model is not intended for research. 

You can find the model and the necessary files for this example in the directory where you installed 
OpenSim (e.g. C:\OpenSim2.3.1\examples\ISB_TGCS_Leg69). 

Part One:  Forward Simulation of the Swing Phase of Gait 

The files for Part One are in the “Swing” folder. 

A.  First, try to come up, by hand, with a set of muscle excitations that will generate swing 
phase motion of the leg during gait: 

1. Load the model leg6dof9muscles.osim.  
2. Load the motion file (File->Load Motion) with the results of Inverse Kinematics 

(leg69_IK_swing.mot) and play it in the GUI. 
3. Stop the motion and rewind to the beginning. Under the Coordinates tab press “Poses” 

and select “Set Default”, which will define the default pose of the model to match the 
start of the IK solution.  

4. Launch the Forward Dynamics tool (Tools->Forward Dynamics). 
5. Check “Solve for equilibrium for actuator states”, which will find initial muscle states 

such that the muscle-fiber and tendon forces are in equilibrium. Controls and States 
inputs are not required. 

6. Specify the time range corresponding to the IK motion (0.117s to 0.617s). 
7. Specify an output directory (e.g. <YourWorkingDir>/Swing/FWD_no_controls) 
8. Save your settings to a file (e.g. leg69_Setup_FWD_no_controls.xml). 
9. Press Run. This will run forward dynamics and output simulated states and applied 

controls to the specified directory. 
10. Replay the resulting motion, and notice that the model falls since there are no ground 

reaction forces to oppose gravity. 
11. Lock the pelvis coordinates (pelvis_tilt, pelvis_tx, pelvis_ty) to prevent the model from 

falling and rerun Forward Dynamics, loading the settings that you saved in step 8. 
12. Replay the resulting motion, then open the plot tool.  How do the kinematics compare to 

the inverse kinematics solution? 
13. Now lets try adding a muscle excitation.  By exciting a single muscle in early swing, can 

you exceed the hip flexion in the inverse kinematics motion file? Modify the controls file 
as follows:  

a. Open the Forward Tool and select the controls from the previous output directory 
(e.g. “FWD_no_controls/leg6dof9musc_controls.sto”) by clicking on the folder 
icon. 
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b. Click the pencil icon and then select a muscle that will generate hip flexion and 
hit OK to edit that muscle’s excitation pattern.   

c. Modify the selected muscle’s excitation in the window that appears.  Hit the help 
button if you need a guide to using the Excitation Editor.  

d. Press the “Save As” button to save your changes to controls to a file (e.g. 
“controls_<muscle>.xml”) 

14. Close the excitation editor and load the modified controls file by pressing the folder icon 
next to the Controls box. 

15. Make sure “Solve for equilibrium actuator states is still checked.” 
16. Specify a new output directory (e.g. Swing/FWD_<muscle_name>) for the one muscle 

excited and hit Run. 
17. By exciting a second muscle in late swing, can you avoid hyper-extending the knee and 

achieve the hip flexion from inverse kinematics?  Repeat the steps above to generate a 
new controls file and forward simulation. 

18. By exciting a third muscle, can you avoid excessive ankle plantarflexion? If yes, what 
muscle? 

19. Repeat this process, adjusting the muscles excitations to create a motion as close to the 
observed swing as possible. 
 

B.  Use static optimization to estimate the muscle excitations for swing: 

1. Launch the Static Optimization Tool 
2. Under Input, select Motion -> From File and open leg69_IK_swing.mot 
3. Check the box to filter coordinates at 6Hz 
4. Check “Use muscle force-length-velocity relation”, which will estimate muscle force 

taking into account the length and velocity of the muscle fiber assuming that muscle-
tendon length changes are due to fiber-length change (i.e. assuming a rigid tendon). 

5. Define the time range. 
6. Specify an output directory for static optimization activations and forces and hit Run. 
7. Compare the muscle activation patterns from static optimization to the activations  from 

the forward simulation with your best set of controls (these can be found in the states.sto 
file from the forward simulation). 
 

C.  Use the muscle activations from Static Optimization to generate a new Forward Dynamics 
simulation of swing:  

1. Launch the Forward Dynamics Tool. 
2. Select the controls file from Static Optimization. 
3. Check “Solve for equilibrium for actuator states”. 
4. Specify the time range of the motion. 
5. Specify the results directory (e.g. Swing/FWD_SO). 
6. Compare the resulting kinematics to the inverse kinematics swing motion. 
7. Compare the resulting activations to static optimization activations. 
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D.  Finally, use Computed Muscle Control to generate a forward simulation of swing: 

1. Launch the Computed Muscle Control Tool. 
2. Under Input, select leg69_IK_swing.mot as the desired kinematics. 
3. Check the box to filter coordinates at 6Hz. 
4. Specify tracking tasks (hip, knee, and ankle tracking and their weightings) by loading the 

tracking tasks file (leg69_CMC_Swing_Tracking_Tasks.xml). 
5. Include actuator control constraints that define the control limits on muscles 

(leg69_muscles_control_limits.xml). 
6. Specify the time range of the motion corresponding to the swing motion from IK. 
7. Choose a CMC look-ahead window that is the approximate time in which muscles can 

change their output force in response to a change in input controls (0.01s). 
8. Specify results directory and hit Run. 
9. Compare the resulting kinematics to the swing motion from IK. 
10. Compare the CMC activations to static optimization activations 
11. Run a forward simulation with the controls from CMC and initial states from CMC (e.g. 

CMC/leg6dof9musc_states.sto) and compare resulting kinematics to IK. 
 

Part Two:  Forward Simulation of the Stance Phase of Gait 

The files for Part Two are in the folder “Stance”. 

A.  Preliminaries 

1. Load the leg6dof9muscles.osim model and unlock the pelvis coordinates. 
2. Close the motions/results from Part One. 
3. Preview the kinematics and ground-reaction forces with the model 

a. Load the motion file, leg69_IK_stance.mot, and hit play. 
b. Under File, choose Preview Motion Data and select leg69_stance_grf.mot 
c. Select both motions: hold the control key, right click to sync motions, and hit 

play. 
 

B.  Use Inverse Dynamics to determine the amount of residual force that is required for the 
model’s dynamics to be consistent with applied ground reaction forces: 

1. Right click the leg69 model and make it the current model. 
2. Launch the Inverse Dynamics tool. 
3. Under Input->Motion->From File, select the stance kinematics mot file. 
4. Check the box to filter kinematics at 6Hz. 
5. Specify the time range as 0.5s to 1.5s, the period in which ground reaction forces are 

defined.  
6. Specify an output directory (e.g. Stance\ID_Results) 
7. Select the External Loads tab and check the External Loads box. 
8. Edit the External Loads settings by clicking the pencil icon. 
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a. Select the leg69_stance_grf.mot as the Force data file.  This file describes the 
force applied at the foot’s center of pressure. 

b. Select leg69_IK_stance.mot  and filter at 6Hz. 
c. Forces listed in the motion file are added as individual forces by hitting the Add 

button. 
i. Provide a name (e.g. “Right_GRF”) 

ii. Applied to body  (e.g. calcn_r) 
iii. Check Applies Force and select Point Force 
iv. Force Columns select “ground_force_vx”, y & z selected automatically 
v. Point Columns select “ground_force_px” 

vi. The GRF free moment is a torque, so check “Applies Torque” 
vii. Torque Columns, scroll down and select “ground_torque_x”  

viii. Both the GRF and CoP are expressed in the ground (lab) frame 
ix. Click OK  

d. Hit Save and enter a filename for the External Force (e.g. 
“leg69_right_GRF.xml”) 

9. Save settings (e.g. “leg69_Setup_ID_stance.xml”), then hit Run. 
10. Plot the forces acting on the pelvis and the net joint moments for the hip, knee and 

ankle. 
11. What accounts for the large residual forces? 

 

C.  Use the RRA tool to reduce residuals.  In other words, adjust the model to compensate for 
model inconsistency with the applied GRFs. 

1. Launch the Reduce Residuals tool. 
2. Specify Desired Kinematics:  leg69_IK_stance.mot. 
3. Check the box to filter kinematics at 6Hz. 
4. Specify the tracking tasks for RRA.  With an XML editor, edit the swing CMC tasks to 

include pelvis kinematics in the set of tracking tasks. If you are not familiar with editing 
XML files, copy the task file provided in Stance/Reference/	
  leg69_Tracking_Tasks.xml 

5. Specify Actuator control constraints.  These constraints define the maximum and 
minimum control limits for all actuators (leg69_residuals_motors_control_limits.xml). 

6. Check “Adjust model”.  Click on the folder icon, make sure you are in the Stance folder, 
and specify a new model name (e.g. leg6dof9musc_adjusted_COM_pelvis.osim).  Hit 
Save.  The “body” (e.g. pelvis) center-of-mass adjustments will be made to this model. 

7. Specify the time range as 0.5s to 1.5s. 
8. Specify an output directory (e.g. Stance\RRA) 
9. Select the “Actuators” tab and choose “Replace model’s force set” to replace the model’s 

muscles with residual and joint motor actuators.  Click Edit and then add 
leg69_RRA_residuals_motors.xml. 

10. Check the External Loads box and specify the file you created for Inverse Dynamics (e.g. 
“leg69_right_GRF.xml”) 

11. Save your settings to an RRA setup file (e.g. leg69_Setup_RRA_stance.xml). 
12. Hit Run. Why does the model “float” down and up? 
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13. Preview the model motion with the GRF again.  To get an estimate for the mass 
adjustment, what phase of the gait should you restrict your RRA analysis to? 

14. Repeat RRA over the new time interval (and save the new settings). What is the 
recommended mass adjustment? (Open up the messages window and locate the 
recommendation from the latest run of RRA, e.g. dmass = 44.037) 

15. Make the recommended mass adjustments to the pelvis of the com-adjusted model 
created by RRA.  

a. To edit the model to make mass adjustments open the Property Editor (Window-
>Properties).  Navigate to the pelvis Body of the com-adjusted model. Edit the 
mass of the pelvis and save the model. Alternatively, use your favorite XML editor 
to edit the model file.  

b. You may also want to rename the model in the Navigator window (e.g. 
leg6dof9musc_adjusted) by right clicking on the current model name and 
selecting Rename. 

16. Re-run RRA with the adjusted model.  Can you get the mass adjustments suggested by 
RRA to be zero? 

17. Plot the RRA residual actuator forces (leg6dof9musc_Actuation_Force.sto, MZ, FX, FY) 
– how do they compare to the forces acting on the pelvis from your ID results?   

18. Plot tracking kinematics outputted by RRA (e.g.	
  leg6dof9musc_Kinematics_q.sto) vs. 
kinematics from IK. 

19. Increase the tracking task weights for coordinates that show poor tracking (via File-
>Edit). Relax tracking weight for coordinates that are within a degree, since the 
optimizer can use this to reduce residuals.  See the handout for more information about 
getting good results from RRA. 

20. Repeat 15 through 19 to converge on a torque driven simulation of single limb stance that 
has minimum residuals with good tracking.  Now you are ready for Computed Muscle 
Control. 
 

D.  Use the Computed Muscle Control (CMC) Tool to determine the muscle excitations, 
activations and forces that generate a forward dynamics simulation of the stance-phase of 
gait. 

1. Load the final adjusted model from RRA 
2. Consider the residual and motor actuators necessary for CMC (e.g. modify 

leg69_RRA_residuals_motors.xml using Edit->File or  an XML editor) 
a. With muscles present, reduce the optimal force of joint motors so that their use 

during CMC is penalized and the use of muscles to generate joint moments is 
favored.  

b. Save the edited the actuators as a new file (e.g.  
leg69_CMC_residuals_motors.xml). 

3. Launch the CMC Tool and select the storage file with output states from RRA (e.g. 
kinematics_q.sto) as the Desired kinematics to track (no filtering is required since the 
kinematics are result of a simulation). 

4. Apply tracking tasks.  Use the same tasks file as for RRA. 
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5. Include limits on muscle actuators by using 
leg69_muscles_residuals_motor_control_limits.xml as Actuator constraints. 

6. Define time range for the stance simulation (same as for RRA). 
7. Specify the output directory (e.g. Stance\CMC).  
8. Append the Actuator set that you created to the model’s force set to include joint motor 

and residual actuators to the set of existing muscles in the model. 
9. Specify the external loads (same as for RRA). 
10. Save your settings to a file. 
11. Run CMC.  If CMC does not execute completely, review the tips and tricks in the handout 

for help with troubleshooting. 
12. How do the kinematics compare to the IK solution for stance? 
13. Run a forward simulation with the controls from CMC and initial states from CMC.  How 

do the kinematics compare to the original IK solution?  Running FD after CMC is a 
method of verifying  that the controls from CMC do in fact generate a forward simulation 
consistent with the observed kinematics and applied GRFs. 

14. Are residuals below 2% of body-weight? 
15. Are the motor moments at the hip, knee and ankle significant? 

 


